OSPF Filtering Using Distribute List with Prefix-List
!
ip prefix-list BLOCK_L0 deny x.x.x.x/xx
ip prefix-list BLOCK_L0 permit x.x.x.x/x
ip prefix-list BLOCK_L0 permit x.x.x.x/x
!
router ospf 1
distribute-list prefix BLOCK_L0 in or out
!
OSPF Filtering Using Distribute List with ACL
!
ip access-list standard BLOCK_L0
deny x.x.x.x
permit any
deny x.x.x.x
permit any
!
router ospf 1
distribute-list BLOCK_L0 in or out
!
OSPF Filtering Using Distribute-List with Route-Map
!
access-list 1 deny x.x.x.x
access-list 1 permit any
!
route-map BLOCK permit 10
match ip address 1
!
router ospf 1
distribute-list route-map BLOCK in
!
access-list 1 deny x.x.x.x
access-list 1 permit any
!
route-map BLOCK permit 10
match ip address 1
!
router ospf 1
distribute-list route-map BLOCK in
!
OSPF Filtering Using Administrative Distance
!
access-list 1 permit x.x.x.x
!
router ospf 1
distance 255 0.0.0.0 255.255.255.255 1 ( distance of 255 = NULL )
!
access-list 1 permit x.x.x.x
!
router ospf 1
distance 255 0.0.0.0 255.255.255.255 1 ( distance of 255 = NULL )
!
OSPF Inter-Area Filtering Using Area Range
!
router ospf 1
area 0 range x.x.x.x x.x.x.x not-advertise
!
router ospf 1
area 0 range x.x.x.x x.x.x.x not-advertise
!
OSPF Inter-Area Filtering using Area Filter-List
!
ip prefix-list BLOCK deny x.x.x.x /xx
ip prefix-list BLOCK permit x.x.x.x /0 le xx
!
router ospf 1
area 0 filter-list prefix BLOCK in or out
!
ip prefix-list BLOCK deny x.x.x.x /xx
ip prefix-list BLOCK permit x.x.x.x /0 le xx
!
router ospf 1
area 0 filter-list prefix BLOCK in or out
!
OSPF LSA Database Filtering
interface X
ip ospf database-filter all out
!
#Config:
!
ip route x.x.x.x x.x.x.x int X
!
OSPF Demand Circuit
!
interface X
ip address x.x.x.x x.x.x.x
ip ospf demand-circuit ( disable hello packets on the interface )
interface X
ip address x.x.x.x x.x.x.x
ip ospf demand-circuit ( disable hello packets on the interface )
!
OSPF Flooding Reductiond
! to be configure on both interfacefacing each other .
interface X
ip address x.x.x.x x.x.x.x
ip ospf flood-reduction
!